using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*/(\w+-\w+)[^/]*$";
string input = @"p/daphne-logo-espadrille/2208098001-BLACK-38-se.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}