package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*/(\w+-\w+)[^/]*$`)
var str = `p/daphne-logo-espadrille/2208098001-BLACK-38-se.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}