$re = '/.*/(\w+-\w+)[^/]*$/m';
$str = 'p/daphne-logo-espadrille/2208098001-BLACK-38-se.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);