const regex = /^Guest Name\s?:\s?(.*?)\s*\r?\nRoom Number\s?:\s?(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Guest Name\\s?:\\s?(.*?)\\s*\\r?\\nRoom Number\\s?:\\s?(.*)', 'gm')
const str = `The description value is Holrest
Code: adip-345
Guest Name : Test_guest1613
Room Number: AK004
Request Number : 107157
Request Method: Email
Dates Requested:25-Jul-2020 08:00PM
If no specific date, weekday or weekend : N/A
Start Time:25-Jul-2020 08:00PM
Time Zone : ET `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}