// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Guest Name\s?:\s?(.*?)\s*\r?\nRoom Number\s?:\s?(.*)").unwrap();
let string = "The description value is Holrest
Code: adip-345
Guest Name : Test_guest1613
Room Number: AK004
Request Number : 107157
Request Method: Email
Dates Requested:25-Jul-2020 08:00PM
If no specific date, weekday or weekend : N/A
Start Time:25-Jul-2020 08:00PM
Time Zone : ET ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}