re = /^Guest Name\s?:\s?(.*?)\s*\r?\nRoom Number\s?:\s?(.*)/m
str = 'The description value is Holrest
Code: adip-345
Guest Name : Test_guest1613
Room Number: AK004
Request Number : 107157
Request Method: Email
Dates Requested:25-Jul-2020 08:00PM
If no specific date, weekday or weekend : N/A
Start Time:25-Jul-2020 08:00PM
Time Zone : ET '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end