package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<message>(?<time>\d{4}-\d{1,2}-\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}) \[(?<thread>[^\]\[]*)] (?<level>\S+)(?<msg>.*))`)
var str = `2013-3-03 14:27:33 [main] INFO Main - Start`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}