$re = '/^(?<message>(?<time>\d{4}-\d{1,2}-\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}) \[(?<thread>[^\]\[]*)] (?<level>\S+)(?<msg>.*))/m';
$str = '2013-3-03 14:27:33 [main] INFO Main - Start';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);