re = /^(?<message>(?<time>\d{4}-\d{1,2}-\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}) \[(?<thread>[^\]\[]*)] (?<level>\S+)(?<msg>.*))/m
str = '2013-3-03 14:27:33 [main] INFO Main - Start'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end