import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^NEVPT2.*\\n(?:(?!end$).*\\n)*end$";
final String string = "JOB 1\n"
+ "CASSCF RESULTS\n"
+ "***\n"
+ "Lots of text\n"
+ "***\n"
+ "end\n"
+ "NEVPT2 RESULTS\n"
+ "***\n"
+ "Lots of text\n"
+ "***\n"
+ "end\n\n"
+ "JOB 2\n"
+ "CASSCF RESULTS\n"
+ "***\n"
+ "Lots of text\n"
+ "***\n"
+ "end\n"
+ "NEVPT2 RESULTS\n"
+ "***\n"
+ "Lots of text\n"
+ "***\n"
+ "end\n"
+ "………………\n"
+ "JOB 31\n"
+ "CASSCF RESULTS\n"
+ "***\n"
+ "Lots of text\n"
+ "***\n"
+ "end\n"
+ "NEVPT2 RESULTS\n"
+ "***\n"
+ "Lots of text\n"
+ "***\n"
+ "end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}