import re
regex = re.compile(r"^NEVPT2.*\n(?:(?!end$).*\n)*end$", flags=re.MULTILINE)
test_str = ("JOB 1\n"
"CASSCF RESULTS\n"
"***\n"
"Lots of text\n"
"***\n"
"end\n"
"NEVPT2 RESULTS\n"
"***\n"
"Lots of text\n"
"***\n"
"end\n\n"
"JOB 2\n"
"CASSCF RESULTS\n"
"***\n"
"Lots of text\n"
"***\n"
"end\n"
"NEVPT2 RESULTS\n"
"***\n"
"Lots of text\n"
"***\n"
"end\n"
"………………\n"
"JOB 31\n"
"CASSCF RESULTS\n"
"***\n"
"Lots of text\n"
"***\n"
"end\n"
"NEVPT2 RESULTS\n"
"***\n"
"Lots of text\n"
"***\n"
"end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")