#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*([-/]).*\1)(?:[A-Z/-]*\d){3,}[A-Z/-]*$"
Local $sString = "02ABU-D9435" & @CRLF & _
"013DFC" & @CRLF & _
"1123451" & @CRLF & _
"03323456782" & @CRLF & _
"ADS7124536768" & @CRLF & _
"03SDFA9433/0" & @CRLF & _
"03SDFA9433/" & @CRLF & _
"03SDFA9433/1" & @CRLF & _
"A41B03423523" & @CRLF & _
"O4AGFC4430"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")