import re
regex = re.compile(r"^(?!.*([-/]).*\1)(?:[A-Z/-]*\d){3,}[A-Z/-]*$", flags=re.MULTILINE)
test_str = ("02ABU-D9435\n"
"013DFC\n"
"1123451\n"
"03323456782\n"
"ADS7124536768\n"
"03SDFA9433/0\n"
"03SDFA9433/\n"
"03SDFA9433/1\n"
"A41B03423523\n"
"O4AGFC4430")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")