$re = '~^(?!.*([-/]).*\1)(?:[A-Z/-]*\d){3,}[A-Z/-]*$~m';
$str = '02ABU-D9435
013DFC
1123451
03323456782
ADS7124536768
03SDFA9433/0
03SDFA9433/
03SDFA9433/1
A41B03423523
O4AGFC4430';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);