using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*([a-zA-Z])[a-zA-Z]\1)[a-zA-Z .]+$";
string input = @"goingforeyecheckup
nan means not a number.
do not match her
match here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}