$re = '/^(?=.*([a-zA-Z])[a-zA-Z]\1)[a-zA-Z .]+$/m';
$str = 'goingforeyecheckup
nan means not a number.
do not match her
match here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);