package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{[0-9]*[^0-9}][^}]*}`)
var str = `something {34dj 4s} and something else {335} and more {dgw} and {6} or whatever`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}