re = /\{[0-9]*[^0-9}][^}]*}/m
str = 'something {34dj 4s} and something else {335} and more {dgw} and {6} or whatever'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end