# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<sup id="fnref:"*.+<\/sup>//gm;t' <<< "<p>A footnote<sup id=\"fnref:1\"><a href=\"#fn:1\" class=\"footnote-ref\" role=\"doc-noteref\">1</a></sup> here. A superscript<sup>®</sup> after it.</p>"