re = /<sup id="fnref:"*.+<\/sup>/m
str = '<p>A footnote<sup id="fnref:1"><a href="#fn:1" class="footnote-ref" role="doc-noteref">1</a></sup> here. A superscript<sup>®</sup> after it.</p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result