package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<sup id="fnref:"*.+</sup>`)
var str = `<p>A footnote<sup id="fnref:1"><a href="#fn:1" class="footnote-ref" role="doc-noteref">1</a></sup> here. A superscript<sup>®</sup> after it.</p>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}