package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(^)(фото.*?)`)
var str = `Фото черное
Белое фото
Фотогалерея синяя
Зеленое фото`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}