$re = '/(?i)(^)(фото.*?)/m';
$str = 'Фото черное
Белое фото
Фотогалерея синяя
Зеленое фото';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);