re = /(?i)(^)(фото.*?)/m
str = 'Фото черное
Белое фото
Фотогалерея синяя
Зеленое фото'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end