package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?(?:0|84)(?:\d){9}$`)
var str = `0349453675
+84349453675
84349453675
1234567
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}