re = /^\+?(?:0|84)(?:\d){9}$/m
str = '0349453675
+84349453675
84349453675
1234567
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end