$re = '/^\+?(?:0|84)(?:\d){9}$/m';
$str = '0349453675
+84349453675
84349453675
1234567
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);