use strict;
my $str = 'SELECT * FROM database;
SELECT * FROM database WHERE somefield = \'somevalue\';
SELECT * FROM database WHERE somefield = "somevalue";
EXPLAIN SELECT * FROM database WHERE somefield = "somevalue";
SELECT * FROM database WHERE somefield = \'somevalue\' AND someotherfield = \'somemistypedstring;
SELECTing is hard, though, this is just text!;
SELECT
*
FROM
test_table
WHERE
test_row = \'Testing ; semicolon\';
SELECT * FROM another_test_table;
INSERT INTO
table_name
VALUES
(value1,\'value which contains semicolon ;;;;\',value3,...);
WITH JOIN parcels
WHERE sp;
select * from accounts;
select * from events_stages_history;';
my $regex = qr/^(?:[\n|\t])*.+?(?:[^;']|(?:'[^']+'))+;$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}