re = /^(?:[\n|\t])*.+?(?:[^;']|(?:'[^']+'))+;$/m
str = 'SELECT * FROM database;
SELECT * FROM database WHERE somefield = \'somevalue\';
SELECT * FROM database WHERE somefield = "somevalue";
EXPLAIN SELECT * FROM database WHERE somefield = "somevalue";
SELECT * FROM database WHERE somefield = \'somevalue\' AND someotherfield = \'somemistypedstring;
SELECTing is hard, though, this is just text!;
SELECT
*
FROM
test_table
WHERE
test_row = \'Testing ; semicolon\';
SELECT * FROM another_test_table;
INSERT INTO
table_name
VALUES
(value1,\'value which contains semicolon ;;;;\',value3,...);
WITH JOIN parcels
WHERE sp;
select * from accounts;
select * from events_stages_history;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end