using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"00[A-Fa-f0-9]{2}FF|00FF[A-Fa-f0-9]{2}|FF00[A-Fa-f0-9]{2}|FF[A-Fa-f0-9]{2}00|[A-Fa-f0-9]{2}00FF|[A-Fa-f0-9]{2}FF00";
string input = @"#FF00A0
#00FFC2
#00D3FF
#E400FF
#F5FF00
#FFB100";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}