re = /00[A-Fa-f0-9]{2}FF|00FF[A-Fa-f0-9]{2}|FF00[A-Fa-f0-9]{2}|FF[A-Fa-f0-9]{2}00|[A-Fa-f0-9]{2}00FF|[A-Fa-f0-9]{2}FF00/
str = '#FF00A0
#00FFC2
#00D3FF
#E400FF
#F5FF00
#FFB100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end