package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?\d{1,3}(\-|\x20)?\(?\d+\)?((\-|\x20)?\d+)+$`)
var str = `+622191755194
622191755194
62-(21)-91755194
62-(21)-9175-5194
62 (21) 9175 5194
+62 (21) 9175 5194`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}