$re = '/^\+?\d{1,3}(\-|\x20)?\(?\d+\)?((\-|\x20)?\d+)+$/m';
$str = '+622191755194
622191755194
62-(21)-91755194
62-(21)-9175-5194
62 (21) 9175 5194
+62 (21) 9175 5194';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);