#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^sms-[0-9]{12}\.xml"
Local $sString = "sms-202309020110.xml" & @CRLF & _
"sms-202309020110.zip" & @CRLF & _
"sms-202309020110.txt" & @CRLF & _
"sms-202392119.xml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")