$re = '/^sms-[0-9]{12}\.xml/i';
$str = 'sms-202309020110.xml
sms-202309020110.zip
sms-202309020110.txt
sms-202392119.xml';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);