package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^sms-[0-9]{12}\.xml`)
var str = `sms-202309020110.xml
sms-202309020110.zip
sms-202309020110.txt
sms-202392119.xml`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}