#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(http|ftp|https):\/\/([\w_-]+(?:(?:\.[\w_-]+)+))([\w.,@^=%&:\/~+-]*[\w@^=%&\/~+-])"
Local $sString = "https://somewebsite.com/awesome?p=isforparameter" & @CRLF & _
"https://somewebsite.com/awesome#anchorsayyyymatey" & @CRLF & _
"https://somewebsite.com/awesome"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")