$re = '/(http|ftp|https):\/\/([\w_-]+(?:(?:\.[\w_-]+)+))([\w.,@^=%&:\/~+-]*[\w@^=%&\/~+-])/i';
$str = 'https://somewebsite.com/awesome?p=isforparameter
https://somewebsite.com/awesome#anchorsayyyymatey
https://somewebsite.com/awesome';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);