const regex = /(http|ftp|https):\/\/([\w_-]+(?:(?:\.[\w_-]+)+))([\w.,@^=%&:\/~+-]*[\w@^=%&\/~+-])/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|ftp|https):\\\/\\\/([\\w_-]+(?:(?:\\.[\\w_-]+)+))([\\w.,@^=%&:\\\/~+-]*[\\w@^=%&\\\/~+-])', 'i')
const str = `https://somewebsite.com/awesome?p=isforparameter
https://somewebsite.com/awesome#anchorsayyyymatey
https://somewebsite.com/awesome`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}