const regex = /(?m)^([A-D]:.*?)correct$((?:\n.*)*?\nx{3,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^([A-D]:.*?)correct$((?:\\n.*)*?\\nx{3,})', 'gm')
const str = `1: How old am I?
A: 8 days
B: 75
C: 100
D: 99correct
xxxxxxxxxxxx
2: What is your favorite color?
A: blue
B: greencorrect
C: red
D: blue
xxxxxxxxxxxx`;
const subst = `\1\2 \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);