# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^([A-D]:.*?)correct$((?:\n.*)*?\nx{3,})"
test_str = ("1: How old am I?\n"
"A: 8 days\n"
"B: 75\n"
"C: 100\n"
"D: 99correct\n"
"xxxxxxxxxxxx\n"
"2: What is your favorite color?\n"
"A: blue\n"
"B: greencorrect\n"
"C: red\n"
"D: blue\n"
"xxxxxxxxxxxx")
subst = "\\1\\2 \\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.