re = /^
(?=(?:[^A-Z]*[A-Z]){2})
(?=(?:[^a-z]*[a-z]){2})
(?=(?:\D*\d){2})
(?=(?:[^$%&!#]*[$%&!#]){2})
.{8,}
$/mx
str = 'a9T%5Q$f
a9T%5r$f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end