#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\+?\d{1,2}\s)?\(?\d{3}\)?[\s.-]\d{3}[\s.-]\d{3,4}(?!\d)"
Local $sString = "my number is (123)-416-567" & @CRLF & _
"1 321 124 7889 is valid" & @CRLF & _
"why not taking 987-012-6782" & @CRLF & _
"120 967 3256 is correct" & @CRLF & _
"call at 888 969 9919" & @CRLF & _
"please text at 1 647 989 1213"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")