re = /(?:\+?\d{1,2}\s)?\(?\d{3}\)?[\s.-]\d{3}[\s.-]\d{3,4}(?!\d)/m
str = 'my number is (123)-416-567
1 321 124 7889 is valid
why not taking 987-012-6782
120 967 3256 is correct
call at 888 969 9919
please text at 1 647 989 1213'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end