const regex = /(?:\+?\d{1,2}\s)?\(?\d{3}\)?[\s.-]\d{3}[\s.-]\d{3,4}(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+?\\d{1,2}\\s)?\\(?\\d{3}\\)?[\\s.-]\\d{3}[\\s.-]\\d{3,4}(?!\\d)', 'gm')
const str = `my number is (123)-416-567
1 321 124 7889 is valid
why not taking 987-012-6782
120 967 3256 is correct
call at 888 969 9919
please text at 1 647 989 1213`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}