# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(`[^`]*)`/$1`;/gm;t' <<< "`Here is my string` this is another test `Here is my string`"