re = /(`[^`]*)`/m
str = '`Here is my string` this is another test `Here is my string`'
subst = '$1`;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result