import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(?<=\")(?!US|CN)(?=\\w{2}\"|\").*";
final String string = "[\n"
+ "[707860,\"UA\",\"Hurzuf\"],\n"
+ "[519188,\"RU\",\"Novinki\"],\n"
+ "[1283378,\"NP\",\"Gorkhā\"],\n"
+ "[1270260,\"IN\",\"State of Haryāna\"],\n"
+ "[708546,\"UA\",\"Holubynka\"],\n"
+ "[1283710,\"NP\",\"Bāgmatī Zone\"],\n"
+ "[529334,\"RU\",\"Mar’ina Roshcha\"],\n"
+ "[529334,\"US\",\"Mar’ina Roshcha\"],\n"
+ "[6255149,\"\",\"North America\"],\n"
+ "[1269750,\"IN\",\"Republic of India\"],\n"
+ "[1283240,\"NP\",\"Kathmandu\"],\n"
+ "[703363,\"UA\",\"Laspi\"],\n"
+ "[3632308,\"VE\",\"Merida\"],\n"
+ "[473537,\"CN\",\"Vinogradovo\"],\n"
+ "[473537,\"RU\",\"Vinogradovo\"],\n"
+ "[384848,\"IQ\",\"Qarah Gawl al ‘Ulyā\"],\n"
+ "[569143,\"RU\",\"Cherkizovo\"],\n"
+ "[713514,\"UA\",\"Alupka\"],\n"
+ "[2878044,\"DE\",\"Lichtenrade\"],\n"
+ "]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}