# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(?<=\")(?!US|CN)(?=\w{2}\"|\").*"
test_str = ("[\n"
"[707860,\"UA\",\"Hurzuf\"],\n"
"[519188,\"RU\",\"Novinki\"],\n"
"[1283378,\"NP\",\"Gorkhā\"],\n"
"[1270260,\"IN\",\"State of Haryāna\"],\n"
"[708546,\"UA\",\"Holubynka\"],\n"
"[1283710,\"NP\",\"Bāgmatī Zone\"],\n"
"[529334,\"RU\",\"Mar’ina Roshcha\"],\n"
"[529334,\"US\",\"Mar’ina Roshcha\"],\n"
"[6255149,\"\",\"North America\"],\n"
"[1269750,\"IN\",\"Republic of India\"],\n"
"[1283240,\"NP\",\"Kathmandu\"],\n"
"[703363,\"UA\",\"Laspi\"],\n"
"[3632308,\"VE\",\"Merida\"],\n"
"[473537,\"CN\",\"Vinogradovo\"],\n"
"[473537,\"RU\",\"Vinogradovo\"],\n"
"[384848,\"IQ\",\"Qarah Gawl al ‘Ulyā\"],\n"
"[569143,\"RU\",\"Cherkizovo\"],\n"
"[713514,\"UA\",\"Alupka\"],\n"
"[2878044,\"DE\",\"Lichtenrade\"],\n"
"]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.