#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Za-z]{1,3}\d{0,10})(?::(?:[A-Za-z]{1,3}\d{0,10}))?$"
Local $sString = "A1" & @CRLF & _
"A1:C4" & @CRLF & _
"AB:AB" & @CRLF & _
"1:1 # don't match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")